SIMTICS Software requires Adobe Flash Player 9.0.124 or higher.
Adobe Flash Player can be downloaded from here.

To install the Adobe Flash Player, you may need to get assistance from your local IT administration.

If you are experiencing any other issues with getting SIMTICS software to run, please contact us through our support web page.